package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b((?:[0-9]{1,3}\.){3}[0-9]{1,3})\b([:/]|$)(([0-9]{1,4})|([\S\d].+))(.*)|$`)
var str = `http://10.213.39.59/path/jklk/llkkk`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}