// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("(?:[^"\\]|\\.)*")|('(?:[^'\\]|\\.)*')|[\S]+"#).unwrap();
let string = "set foo \"bar\\\" baz\" asdflkj
set foo 'bar\"\" baz' # this is a comment
set foo 'bar # nested comment'
set foo \"bar'\"asdfasdf\"' baz\"
set foo 'bar \"boom \\'clap\\'\" baz'; get foo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}