#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "("(?:[^"\\]|\\.)*")|('(?:[^'\\]|\\.)*')|[\S]+"
Local $sString = "set foo "bar\" baz" asdflkj" & @CRLF & _
"set foo 'bar"" baz' # this is a comment" & @CRLF & _
"set foo 'bar # nested comment'" & @CRLF & _
"set foo "bar'"asdfasdf"' baz"" & @CRLF & _
"" & @CRLF & _
"set foo 'bar "boom \'clap\'" baz'; get foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")