$re = '/("(?:[^"\\\\]|\\\\.)*")|(\'(?:[^\'\\\\]|\\\\.)*\')|[\S]+/';
$str = 'set foo "bar\\" baz" asdflkj
set foo \'bar"" baz\' # this is a comment
set foo \'bar # nested comment\'
set foo "bar\'"asdfasdf"\' baz"
set foo \'bar "boom \\\'clap\\\'" baz\'; get foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);