package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("(?:[^"\\]|\\.)*")|('(?:[^'\\]|\\.)*')|[\S]+`)
var str = `set foo "bar\" baz" asdflkj
set foo 'bar"" baz' # this is a comment
set foo 'bar # nested comment'
set foo "bar'"asdfasdf"' baz"
set foo 'bar "boom \'clap\'" baz'; get foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}