using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""(?:[^""\\]|\\.)*"")|('(?:[^'\\]|\\.)*')|[\S]+";
string input = @"set foo ""bar\"" baz"" asdflkj
set foo 'bar"" baz' # this is a comment
set foo 'bar # nested comment'
set foo ""bar'""asdfasdf""' baz""
set foo 'bar ""boom \'clap\'"" baz'; get foo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}