re = /("(?:[^"\\]|\\.)*")|('(?:[^'\\]|\\.)*')|[\S]+/
str = 'set foo "bar\\" baz" asdflkj
set foo \'bar"" baz\' # this is a comment
set foo \'bar # nested comment\'
set foo "bar\'"asdfasdf"\' baz"
set foo \'bar "boom \\\'clap\\\'" baz\'; get foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end