re = /(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$/
str = 'Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum'
# Print the match result
str.match(re) do |match|
puts match.to_s
end