$re = '/(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$/';
$str = 'Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);