using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$";
string input = @"Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}