use strict;
my $str = 'Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum';
my $regex = qr/(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}