#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$"
Local $sString = "Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")