const regex = /(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*(Microsoft-Windows-InternetExplorer-).*(11\\.).*(\\.mum))$', '')
const str = `Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}