// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-\s+)(lat)(.*)(\n\s*)(long)").unwrap();
let string = "- lat: \"-82.645672\"
long: '44.941747'
title: \"Item 1\"
- lat: \"-82.645744\"
long: '44.940731'
title: \"Item 2\"
- lat: \"-82.645744\"
long: '44.940731'
title: \"Item 3\"
- lat: \"-82.646599\"
long: '44.941441'
title: \"Item 4\"";
let substitution = "$1$5$3$4$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}