const regex = /^(-\s+)(lat)(.*)(\n\s*)(long)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-\\s+)(lat)(.*)(\\n\\s*)(long)', 'gm')
const str = `- lat: "-82.645672"
long: '44.941747'
title: "Item 1"
- lat: "-82.645744"
long: '44.940731'
title: "Item 2"
- lat: "-82.645744"
long: '44.940731'
title: "Item 3"
- lat: "-82.646599"
long: '44.941441'
title: "Item 4"`;
const subst = `$1$5$3$4$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);