# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(-\s+)(lat)(.*)(\n\s*)(long)/$1$5$3$4$2/gm;t' <<< "- lat: \"-82.645672\"
long: '44.941747'
title: \"Item 1\"
- lat: \"-82.645744\"
long: '44.940731'
title: \"Item 2\"
- lat: \"-82.645744\"
long: '44.940731'
title: \"Item 3\"
- lat: \"-82.646599\"
long: '44.941441'
title: \"Item 4\""