import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-\\s+)(lat)(.*)(\\n\\s*)(long)";
final String string = "- lat: \"-82.645672\"\n"
+ " long: '44.941747'\n"
+ " title: \"Item 1\"\n"
+ "- lat: \"-82.645744\"\n"
+ " long: '44.940731'\n"
+ " title: \"Item 2\"\n"
+ "- lat: \"-82.645744\"\n"
+ " long: '44.940731'\n"
+ " title: \"Item 3\"\n"
+ "- lat: \"-82.646599\"\n"
+ " long: '44.941441'\n"
+ " title: \"Item 4\"";
final String subst = "$1$5$3$4$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}