#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(-\s+)(lat)(.*)(\n\s*)(long)"
Local $sString = "- lat: "-82.645672"" & @CRLF & _
" long: '44.941747'" & @CRLF & _
" title: "Item 1"" & @CRLF & _
"- lat: "-82.645744"" & @CRLF & _
" long: '44.940731'" & @CRLF & _
" title: "Item 2"" & @CRLF & _
"- lat: "-82.645744"" & @CRLF & _
" long: '44.940731'" & @CRLF & _
" title: "Item 3"" & @CRLF & _
"- lat: "-82.646599"" & @CRLF & _
" long: '44.941441'" & @CRLF & _
" title: "Item 4""
Local $sSubst = "$1$5$3$4$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)