$re = '/^(-\s+)(lat)(.*)(\n\s*)(long)/m';
$str = '- lat: "-82.645672"
long: \'44.941747\'
title: "Item 1"
- lat: "-82.645744"
long: \'44.940731\'
title: "Item 2"
- lat: "-82.645744"
long: \'44.940731\'
title: "Item 3"
- lat: "-82.646599"
long: \'44.941441\'
title: "Item 4"';
$subst = "$1$5$3$4$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;