// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\s*<div\s[^"]*\"feature-bullets\"\s[\s\S]*(<ul[\s\S]*<\/ul>)"#).unwrap();
let string = "<div id=\"feature-bullets\" class=\"a-section a-spacing-medium a-spacing-top-small\">
<ul class=\"a-unordered-list a-vertical a-spacing-none\">
<li><span class=\"a-list-item\">
100% Leather
</span></li>
<li><span class=\"a-list-item\">
Imported
</span></li>
<li><span class=\"a-list-item\">
Rubber sole
</span></li>
<li><span class=\"a-list-item\">
Removable insole
</span></li>
</ul>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}