#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*<div\s[^"]*\"feature-bullets\"\s[\s\S]*(<ul[\s\S]*<\/ul>)"
Local $sString = "<div id="feature-bullets" class="a-section a-spacing-medium a-spacing-top-small">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <ul class="a-unordered-list a-vertical a-spacing-none">" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" 100% Leather" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Imported" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Rubber sole" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Removable insole" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" </ul>" & @CRLF & _
" " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")