using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*<div\s[^""]*\""feature-bullets\""\s[\s\S]*(<ul[\s\S]*<\/ul>)";
string input = @"<div id=""feature-bullets"" class=""a-section a-spacing-medium a-spacing-top-small"">
<ul class=""a-unordered-list a-vertical a-spacing-none"">
<li><span class=""a-list-item"">
100% Leather
</span></li>
<li><span class=""a-list-item"">
Imported
</span></li>
<li><span class=""a-list-item"">
Rubber sole
</span></li>
<li><span class=""a-list-item"">
Removable insole
</span></li>
</ul>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}