const regex = /\s*<div\s[^"]*\"feature-bullets\"\s[\s\S]*(<ul[\s\S]*<\/ul>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*<div\\s[^"]*\\"feature-bullets\\"\\s[\\s\\S]*(<ul[\\s\\S]*<\\\/ul>)', 'gm')
const str = `<div id="feature-bullets" class="a-section a-spacing-medium a-spacing-top-small">
<ul class="a-unordered-list a-vertical a-spacing-none">
<li><span class="a-list-item">
100% Leather
</span></li>
<li><span class="a-list-item">
Imported
</span></li>
<li><span class="a-list-item">
Rubber sole
</span></li>
<li><span class="a-list-item">
Removable insole
</span></li>
</ul>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}