re = /\s*<div\s[^"]*\"feature-bullets\"\s[\s\S]*(<ul[\s\S]*<\/ul>)/m
str = '<div id="feature-bullets" class="a-section a-spacing-medium a-spacing-top-small">
<ul class="a-unordered-list a-vertical a-spacing-none">
<li><span class="a-list-item">
100% Leather
</span></li>
<li><span class="a-list-item">
Imported
</span></li>
<li><span class="a-list-item">
Rubber sole
</span></li>
<li><span class="a-list-item">
Removable insole
</span></li>
</ul>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end