import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*<div\\s[^\"]*\\\"feature-bullets\\\"\\s[\\s\\S]*(<ul[\\s\\S]*<\\/ul>)";
final String string = "<div id=\"feature-bullets\" class=\"a-section a-spacing-medium a-spacing-top-small\">\n\n\n\n\n\n\n\n\n"
+ " \n"
+ " \n"
+ " <ul class=\"a-unordered-list a-vertical a-spacing-none\">\n"
+ " \n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " 100% Leather\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Imported\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Rubber sole\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Removable insole\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " </ul>\n"
+ " \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}