import Foundation
let pattern = #"([0-9]{4})\.([0-9]{2})\.([0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2017.10.02
2015.08.09
2017-05-02
20190908
log-2017.10.02
notification-2015.08.09-name
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)