import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{4})\\.([0-9]{2})\\.([0-9]{2})";
final String string = "2017.10.02\n"
+ "2015.08.09\n"
+ "2017-05-02\n"
+ "20190908\n"
+ "log-2017.10.02\n"
+ "notification-2015.08.09-name";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}