use strict;
my $str = '2017.10.02
2015.08.09
2017-05-02
20190908
log-2017.10.02
notification-2015.08.09-name';
my $regex = qr/([0-9]{4})\.([0-9]{2})\.([0-9]{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}