#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9]{4})\.([0-9]{2})\.([0-9]{2})"
Local $sString = "2017.10.02" & @CRLF & _
"2015.08.09" & @CRLF & _
"2017-05-02" & @CRLF & _
"20190908" & @CRLF & _
"log-2017.10.02" & @CRLF & _
"notification-2015.08.09-name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")