package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{4})\.([0-9]{2})\.([0-9]{2})`)
var str = `2017.10.02
2015.08.09
2017-05-02
20190908
log-2017.10.02
notification-2015.08.09-name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}