re = /([0-9]{4})\.([0-9]{2})\.([0-9]{2})/
str = '2017.10.02
2015.08.09
2017-05-02
20190908
log-2017.10.02
notification-2015.08.09-name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end