# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((http|ftp)s?:.*?) "
test_str = ("< Div > \n"
" < div id = \"header_col2\" > \n"
" < a href = \"index_en.xhtml\" title = \"Angol version\" > \n"
" < img src = \"eng.jpg\" alt = \"Angol\" height = \"25\" width = \"48 \" / > \n"
" < / a > \n"
" < / div > \n"
" < / div > \n"
" < div id = \" clear \" > \n"
" < hr / > \n"
" <h2 > Some links < / h2 >\n"
" < P > \n"
" < a href = \"http://www.math.bme.hu/algebra \" > Department of Algebra < / a > < br / > \n"
" < a href = \"http://www.math.bme.hu/ \" > matematics institude < / a > < br / > \n"
" < a href = \" http://www.bme.hu/ \" > BME < / a > < br / > \n"
" < a href = \" http://www.bme.hu/~kk0v4cs \" > Something else < / a > <br / > \n"
" < / p> \n"
" < / div >")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.