use strict;
my $str = '< Div >
< div id = "header_col2" >
< a href = "index_en.xhtml" title = "Angol version" >
< img src = "eng.jpg" alt = "Angol" height = "25" width = "48 " / >
< / a >
< / div >
< / div >
< div id = " clear " >
< hr / >
<h2 > Some links < / h2 >
< P >
< a href = "http://www.math.bme.hu/algebra " > Department of Algebra < / a > < br / >
< a href = "http://www.math.bme.hu/ " > matematics institude < / a > < br / >
< a href = " http://www.bme.hu/ " > BME < / a > < br / >
< a href = " http://www.bme.hu/~kk0v4cs " > Something else < / a > <br / >
< / p>
< / div >';
my $regex = qr/((http|ftp)s?:.*?) /p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}