import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http|ftp)s?:.*?) ";
final String string = "< Div > \n"
+ " < div id = \"header_col2\" > \n"
+ " < a href = \"index_en.xhtml\" title = \"Angol version\" > \n"
+ " < img src = \"eng.jpg\" alt = \"Angol\" height = \"25\" width = \"48 \" / > \n"
+ " < / a > \n"
+ " < / div > \n"
+ " < / div > \n"
+ " < div id = \" clear \" > \n"
+ " < hr / > \n"
+ " <h2 > Some links < / h2 >\n"
+ " < P > \n"
+ " < a href = \"http://www.math.bme.hu/algebra \" > Department of Algebra < / a > < br / > \n"
+ " < a href = \"http://www.math.bme.hu/ \" > matematics institude < / a > < br / > \n"
+ " < a href = \" http://www.bme.hu/ \" > BME < / a > < br / > \n"
+ " < a href = \" http://www.bme.hu/~kk0v4cs \" > Something else < / a > <br / > \n"
+ " < / p> \n"
+ " < / div >";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}