const regex = /((http|ftp)s?:.*?) /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http|ftp)s?:.*?) ', 'g')
const str = `< Div >
< div id = "header_col2" >
< a href = "index_en.xhtml" title = "Angol version" >
< img src = "eng.jpg" alt = "Angol" height = "25" width = "48 " / >
< / a >
< / div >
< / div >
< div id = " clear " >
< hr / >
<h2 > Some links < / h2 >
< P >
< a href = "http://www.math.bme.hu/algebra " > Department of Algebra < / a > < br / >
< a href = "http://www.math.bme.hu/ " > matematics institude < / a > < br / >
< a href = " http://www.bme.hu/ " > BME < / a > < br / >
< a href = " http://www.bme.hu/~kk0v4cs " > Something else < / a > <br / >
< / p>
< / div >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}