#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((http|ftp)s?:.*?) "
Local $sString = "< Div > " & @CRLF & _
" < div id = "header_col2" > " & @CRLF & _
" < a href = "index_en.xhtml" title = "Angol version" > " & @CRLF & _
" < img src = "eng.jpg" alt = "Angol" height = "25" width = "48 " / > " & @CRLF & _
" < / a > " & @CRLF & _
" < / div > " & @CRLF & _
" < / div > " & @CRLF & _
" < div id = " clear " > " & @CRLF & _
" < hr / > " & @CRLF & _
" <h2 > Some links < / h2 >" & @CRLF & _
" < P > " & @CRLF & _
" < a href = "http://www.math.bme.hu/algebra " > Department of Algebra < / a > < br / > " & @CRLF & _
" < a href = "http://www.math.bme.hu/ " > matematics institude < / a > < br / > " & @CRLF & _
" < a href = " http://www.bme.hu/ " > BME < / a > < br / > " & @CRLF & _
" < a href = " http://www.bme.hu/~kk0v4cs " > Something else < / a > <br / > " & @CRLF & _
" < / p> " & @CRLF & _
" < / div >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")