using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((http|ftp)s?:.*?) ";
string input = @"< Div >
< div id = ""header_col2"" >
< a href = ""index_en.xhtml"" title = ""Angol version"" >
< img src = ""eng.jpg"" alt = ""Angol"" height = ""25"" width = ""48 "" / >
< / a >
< / div >
< / div >
< div id = "" clear "" >
< hr / >
<h2 > Some links < / h2 >
< P >
< a href = ""http://www.math.bme.hu/algebra "" > Department of Algebra < / a > < br / >
< a href = ""http://www.math.bme.hu/ "" > matematics institude < / a > < br / >
< a href = "" http://www.bme.hu/ "" > BME < / a > < br / >
< a href = "" http://www.bme.hu/~kk0v4cs "" > Something else < / a > <br / >
< / p>
< / div >";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}