import Foundation
let pattern = #"^(?:(?:git@github\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\w+)/(?P<name>[\w-]+))(?:\.git)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://github.com/argoai/labeling.git
git@github.com:argoai/lme-common.git
git@github.com:/argoai/labeling.git
git@github.com:/argoai/labeling
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)