// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:git@github\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\w+)/(?P<name>[\w-]+))(?:\.git)?$").unwrap();
let string = "https://github.com/argoai/labeling.git
git@github.com:argoai/lme-common.git
git@github.com:/argoai/labeling.git
git@github.com:/argoai/labeling";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}