re = /^(?:(?:git@github\.com:)|(?:https:\/\/github.com))\/?(?P<github_path>(?P<owner>\w+)\/(?P<name>[\w-]+))(?:\.git)?$/m
str = 'https://github.com/argoai/labeling.git
git@github.com:argoai/lme-common.git
git@github.com:/argoai/labeling.git
git@github.com:/argoai/labeling'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end