using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:git@github\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\w+)/(?P<name>[\w-]+))(?:\.git)?$";
string input = @"https://github.com/argoai/labeling.git
git@github.com:argoai/lme-common.git
git@github.com:/argoai/labeling.git
git@github.com:/argoai/labeling";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}