package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:git@github\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\w+)/(?P<name>[\w-]+))(?:\.git)?$`)
var str = `https://github.com/argoai/labeling.git
git@github.com:argoai/lme-common.git
git@github.com:/argoai/labeling.git
git@github.com:/argoai/labeling`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}