#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:git@github\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\w+)/(?P<name>[\w-]+))(?:\.git)?$"
Local $sString = "https://github.com/argoai/labeling.git" & @CRLF & _
"git@github.com:argoai/lme-common.git" & @CRLF & _
"git@github.com:/argoai/labeling.git" & @CRLF & _
"git@github.com:/argoai/labeling"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")