// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-zA-Z_\.-].[\.com|\.org|\.US]$").unwrap();
let string = "gmail.com
www@google
www.Coursera.org
web-address.com/homepage
My_Favorite-Blog.US";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}