re = /[a-zA-Z_\.-].[\.com|\.org|\.US]$/m
str = 'gmail.com
www@google
www.Coursera.org
web-address.com/homepage
My_Favorite-Blog.US'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end