package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z_\.-].[\.com|\.org|\.US]$`)
var str = `gmail.com
www@google
www.Coursera.org
web-address.com/homepage
My_Favorite-Blog.US`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}