$re = '/[a-zA-Z_\.-].[\.com|\.org|\.US]$/m';
$str = 'gmail.com
www@google
www.Coursera.org
web-address.com/homepage
My_Favorite-Blog.US';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);