using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z_\.-].[\.com|\.org|\.US]$";
string input = @"gmail.com
www@google
www.Coursera.org
web-address.com/homepage
My_Favorite-Blog.US";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}