import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z_\\.-].[\\.com|\\.org|\\.US]$";
final String string = "gmail.com\n"
+ "www@google\n"
+ "www.Coursera.org\n"
+ "web-address.com/homepage\n"
+ "My_Favorite-Blog.US";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}