// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([A-Za-z_]+)|\"[^".]+\"|([>,])"#).unwrap();
let string = "jsx_expression > \"{\", jsx_expression > \",\"
template_substitution > \"${\"
template_substitution > foo , bar
foo > bar > baz
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}